BriskBard updated to the version 1.3.1

The new version BriskBard 1.3.1 has been launched and now it uses the version 56.0.2924.76 of Blink.

An issue with the ordering of email messages is now fixed too.

For more information got to https://www.briskbard.com

BriskBard BriskBard BriskBard

English