Errors in console

Post Reply
thefunkyjoint
Posts: 330
Joined: Thu Aug 10, 2017 12:40 pm

Errors in console

Post by thefunkyjoint »

Hi,

I've noticed that console shows a lot of errors like these :

Uncaught (in promise) NotSupportedError: Failed to execute 'addSourceBuffer' on 'MediaSource': The type provided ('video/mp4; codecs="avc1.42C01E"') is unsupported. :
Uncaught (in promise) NotSupportedError: Failed to execute 'addSourceBuffer' on 'MediaSource': The type provided ('audio/mp4; codecs="mp4a.40.5"') is unsupported. :

Is there a way to disable mp4 / avi loading, in order to avoid these messages ?

Thanks !
User avatar
salvadordf
Posts: 3067
Joined: Thu Feb 02, 2017 12:24 pm
Location: Spain
Contact:

Re: Errors in console

Post by salvadordf »

Those errors seem to be caused by unsupported video and audio codecs.

Setting GlobalCEFApp.AutoplayPolicy to appDocumentUserActivationRequired to stop autoplay might be a workaround but building the CEF binaries with proprietary codec support would be a better solution.
thefunkyjoint
Posts: 330
Joined: Thu Aug 10, 2017 12:40 pm

Re: Errors in console

Post by thefunkyjoint »

salvadordf wrote: Tue Oct 01, 2019 9:01 pm Those errors seem to be caused by unsupported video and audio codecs.

Setting GlobalCEFApp.AutoplayPolicy to appDocumentUserActivationRequired to stop autoplay might be a workaround but building the CEF binaries with proprietary codec support would be a better solution.
Thanks for the info ; can i set AutoPlayPolicy per TChromium instance, or is it only global ?
User avatar
salvadordf
Posts: 3067
Joined: Thu Feb 02, 2017 12:24 pm
Location: Spain
Contact:

Re: Errors in console

Post by salvadordf »

I tried to modify the "profile.default_content_setting_values.autoplay" preference to set a custom autoplay value for each TChromium browser but it seems to be ignored.

For now, only the GlobalCEFApp autoplay property works.
yarockiisergei
Posts: 2
Joined: Wed Aug 18, 2021 10:44 pm

Re: Errors in console

Post by yarockiisergei »

thefunkyjoint wrote: Tue Oct 01, 2019 7:21 pm Hi,

I've noticed that console shows a lot of errors like these :

Uncaught (in promise) NotSupportedError: Failed to execute 'addSourceBuffer' on 'MediaSource': The type provided ('video/mp4; codecs="avc1.42C01E"') is unsupported. :
Uncaught (in promise) NotSupportedError: Failed to execute 'addSourceBuffer' on 'MediaSource': The type provided ('audio/mp4; codecs="mp4a.40.5"') is unsupported. :

Is there a way to disable mp4 / avi loading, in order to avoid these messages ?

Thanks !
Last edited by yarockiisergei on Wed Aug 18, 2021 10:58 pm, edited 1 time in total.
Post Reply