Issues with Browser events

Post Reply
umpani
Posts: 9
Joined: Thu Nov 01, 2018 2:17 pm

Issues with Browser events

Post by umpani » Thu Jan 16, 2020 11:57 am

Hello,

at first, I would like to thank you for your great work with this component.

I have noticed sometimes a very strange behavior. In 99% of all cases, the component works fine. The pages are loaded fine and all browser events (eg. OnPageLoaded, OnAddressChanged ..) are executed immediately. But sometimes (always directly after a Thursday) the component executes not a single browserevent. The only fix is to restart the system. Sometimes you even have to install the Thursdays Windows 10 updates first. This behavior occurs not just at a single system, but at a lot of very different systems (VMs, Desktop, Laptops). But all oft he systems are Windows 10 based.

Perhaps you have an idea, why thiss phenomenon occurs and (more important) how to fix it.

Thank you

Greetings
Benno

User avatar
salvadordf
Posts: 2068
Joined: Thu Feb 02, 2017 12:24 pm
Location: Spain
Contact:

Re: Issues with Browser events

Post by salvadordf » Thu Jan 16, 2020 12:08 pm

Hi,

Perhaps the antivirus or Windows is checking the EXE and all the DLLs before loading them.
Try signing them or adding them to the antivirus whitelist to see if that fixes this issue.

umpani
Posts: 9
Joined: Thu Nov 01, 2018 2:17 pm

Re: Issues with Browser events

Post by umpani » Thu Jan 16, 2020 1:37 pm

Ok, thanks.

I will try to sign the dlls and report the experiences here.

Post Reply