What are the minimum system requirements to use BriskBard?

  • Windows XP (SP3), Vista, 7, 8, 8.1, 10 or better.
  • Any CPU with SSE instructions (Pentium III or better).
  • 20MiB free disk space.

Legal notesBriskBard's EULA (End User License Agreement)About meSitemapSearch
Copyright © 2016  All rights reserved.
Cookie usage

By browsing our site you agree to our use of cookies. You will only see this message once.
Find out more
Ok